This project is read-only.

Trying to setup GameOn

Aug 30, 2012 at 9:20 PM

Hello,

I'm trying to setup this Ladder website that you've developed (great idea by the way), but am running into some troubles. I've got IIS running on my computer and have added a virtual directory (called GameOn) pointing to the contents of the Package folder from the GameOn-1.0.0-Web-Package.zip file.

In the readme file it mentions that I should point IIS to the package/change-set directory however I don't have that directory. I have App_Data, bin, Contents, Scripts, Views, Global.asax, ReadMe.txt and Web.config.

Am I missing something? When I got to http://<machinename>/GameOn/Global.asax it just downloads the file.

Please help!

Thanks in advance.

Aug 31, 2012 at 10:42 AM

Hi Willy,

I have added extra instructions to IIS Installation, under "installing in a virtual directory. I hope this helps. If you are using II6 and need more help, let me know.

- Daniel

Sep 4, 2012 at 9:17 PM

Hi Daniel!  thanks for your response.   I got it to work on IIS with windows 7,   But when I open the main URL, i get the following javascript error: 

ReferenceError: RenderSparklines is not defined

The page displays and is otherwise appears to be OK... except that the "Play" button does not seem to respond.
Sep 4, 2012 at 9:23 PM

These resources are not loading because it is referencing an incorrect path:

http://localhost:8181/Scripts/jquery.sparkline.js
http://localhost:8181/Scripts/GameOn.Sparklines.js
http://localhost:8181/Scripts/jquery.sparkline.js
http://localhost:8181/Scripts/GameOn.Sparklines.js

These should be the following in my case:

http://localhost:8181/Package/Scripts/jquery.sparkline.js

Interestingly, others such as Jquery mobile *IS* loading...  but they are referencing an external path on the internet:

http://code.jquery.com/mobile/1.1.0/jquery.mobile-1.1.0.min.css

 

Sep 4, 2012 at 9:29 PM

Also,    'http://localhost:8181/Players/GetSparklinesData'  seems to be failing with 404 not found.      Not sure if I'm missing something from the zip package.

Sep 4, 2012 at 9:57 PM

Daniel,  I figured it out...  It appears this application is not able to live under a sub virtual directory,  all the paths want to map to the root.   So I installed the application into the root directory of a new IIS website, and that worked.

Sep 10, 2012 at 10:16 AM

Nice one hiro5id ! :D